Partial DNS Outage

Incident Report for DonorDock

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 16:45 CDT

Monitoring

We have moved the services to a new service provider and will expect the issues to reduce over the coming hour. We will continue to monitor and update accordingly.
Posted Mar 16, 2026 - 15:11 CDT

Update

We are working on moving the affected services away from Go Daddy to another service provider. We will provide another update soon.
Posted Mar 16, 2026 - 14:52 CDT

Identified

We have confirmed there is an issue with one of our service providers, Go Daddy. The issue has been escalated within Go Daddy, and we hope they are able to deploy a fix shortly.
Posted Mar 16, 2026 - 14:24 CDT

Update

We have confirmed there is an issue with one of our service providers, Go Daddy. The issue has been escalated within Go Daddy, and we hope they are able to deploy a fix shortly.
Posted Mar 16, 2026 - 14:22 CDT

Investigating

Starting at about 12:30CDT, we began seeing intermittent DNS failures. This is not affecting all customers. We are currently investigating the cause, and will post an update soon.
Posted Mar 16, 2026 - 13:36 CDT
This incident affected: API, CRM Application, Login Application, Online Giving Application, and Web Forms Application.