Service Provider Outage

Incident Report for DonorDock

Resolved

Services have remained stable under for several hours, and Microsoft has reported the Azure Front Door (AFD) issue as resolved. Normal operations have been fully restored.
Posted Oct 29, 2025 - 23:53 CDT

Update

Services remain operational under our failover strategy. We continue to monitor the situation with our cloud service provider (Microsoft Azure) as they work to restore the Azure Front Door (AFD) service.

Updates from Microsoft can be found at: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 15:17 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 12:33 CDT

Monitoring

We have implemented a mitigation to restore services. We are monitoring the issue and will provide another update once services are fully restored.
Posted Oct 29, 2025 - 12:29 CDT

Update

Starting at approximately 16:00 UTC, Microsoft Azure, our cloud provider began experiencing DNS issues resulting in availability degradation of some services. They are actively investigating the underlying issue and additional mitigation actions. More information will be provided when available.
Posted Oct 29, 2025 - 11:43 CDT

Identified

We are currently experiencing an issue with our cloud provider and are awaiting further details. We are working to restore services as quickly as possible.
Posted Oct 29, 2025 - 11:22 CDT
This incident affected: API, CRM Application, Login Application, Online Giving Application, and Web Forms Application.