Identified an issue impacting application access. We are actively performing steps to restore access shortly.

Incident Report for DonorDock

Resolved

This incident has been resolved.
Posted Apr 07, 2023 - 09:27 CDT

Update

We have identified and fixed the issue. All systems are operational.
Posted Apr 07, 2023 - 09:27 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2023 - 09:23 CDT
This incident affected: API, CRM Application, Login Application, Online Giving Application, and Web Forms Application.