Service Down

Incident Report for DonorDock

Resolved

Systems have been stable. Incident has been resolved.
Posted Nov 20, 2025 - 09:00 CST

Monitoring

Access is restored. We will continue to monitor for any issues.
Posted Nov 20, 2025 - 08:56 CST

Investigating

We are currently investigating an issue with services that is preventing customers for accessing their accounts.
Posted Nov 20, 2025 - 08:34 CST
This incident affected: API, CRM Application, Login Application, Online Giving Application, and Web Forms Application.